[SOLVED] Clone cockpit to other server

i am trying to move my installation to another server but without success.

My installation uses SQLlite and I read that it was enough to copy all the files and move but it doesn’t work.

The login screen always gives me {ERROR}

Why does it do this?

We need some more information…

Is it a shared host? Did you try to adjust some constants via defines.php to fix wrong path detections?

Due to the placeholder { ERROR } I’m sure, that the required scripts couldn’t be loaded. Have a look at the network tab of your browser dev console. The assets point to a wrong location.

I solved the import of the files.

In order not to go crazy in case even those with the same problem.

I found the error by creating the .zip folder from my Windows PC, noting that decompression on the server was putting incorrect permissions.

I have done compression from staging hosting and imported to other server and everything is working properly.

I ask if anyone knows how to do it even makes a simple folder on the pc

Ah, I see. I had these Windows problems, too. My workaround is to do as much as possible server side. I clone/download cockpit and all addons via ssh and then I copy only the config and storage folders. This saves a lot of time, because SFTP is very slow and it resolves the Windows permission problems on the fly.