Cannot reach cockpit in deployed app


#1

I have deployed an app from GitHub using a Jenkins pipeline to Pivotal Cloud Foundry. I am able to reach my index.html page, but trying to reach cockpit gets me a 500 error. Eventually I plan to use mongodb, but I wanted to see if I could get it up and running first with just sqlite. I am wondering if I am missing something in the config files. Everything works great locally using MAMP. Any help or advice is much appreciated.


#2

if you are running an apache webserver try commenting in the rewritebase row within the .htaaccess (not quite sure if this will fix your issue, but I had the same problem once and commenting the rewrite base back in again fixed if for me)


#3

Unfortunately, that fix did not work. I realize I have been able to get Drupal installed in the past. I will try to compare the setup to see if an answer can be found there. I think it has something to do with my buildpack.


#4

Solved this issue, but created another one. When looking at my logs I noticed an error was occurring when checking which version of Apache I have. I removed the check after checking my version number. Now I have to give write access to some of the directories in the storage folder. Trying to figure that out now.


#5

I am getting these errors when trying to install:

  • PDO extension loaded with Sqlite support

  • Data folder is not writable: /storage/data

  • Cache folder is not writable: /storage/cache

  • Temp folder is not writable: /storage/tmp

  • Uploads folder is not writable: /storage/uploads

When I check my phpinfo I am showing sqlite as installed. If I ssh into the server and create the directories that are said not to be writable the errors disappear except for the pdo extension error. From what I can tell it is installed. I am not sure why I can’t get it to work with cockpit though.

edit: solved with newest version of cockpit