A bit of random error 404 when setting up cockpit


I did install cockpit CMS on a hosting provider that runs php 8.2 on Apache.
First I installed it once on a separate subdomain and it all worked. I was able to create models, content, users, roles, api-keys. This was my playground.
Then I installed it again, this time in a subfolder of an existing environment. It looked fine at first. I could create models, content, user, api-key. Then I create a user-role but after I created it I could not manage roles any longer. Attemtping to navigate to manage roles would result in a 404 page.
Then I installed it again in a subdomain, directly on the root and it seemed again all to work but after I have created the models I could not access them. Each time I want to edit them or add content I end up on a 404 page.
I tried again the page where I installed cockpit on a sub folder and for some reason all of a sudden I am able to manage roles there again. I wonder if a cleanup from the hosting provider somehow has solved this problem.

Now I want to ask: What means do I have with cockpit CMS to investigate the issue and find out what is going wrong. I see there is a log folder but I see no logs there. I cannot access the apache logs, only the hosting provider can. I see there is a debug mode in cockpit, I am not clear what it does and how I could activate it.

What can I do?

Hi :wave:

Do you have access to apache and php error logs?

Unfortunately not, no.