CpMultiplate page not found

Hi everyone,
i tried to install CPmultiplane locally. I followed the guide on this site: https://monoplane.rlj.me/en/first-test-setup

First of all:
asks me for username and password to download this module:
git clone https://github.com/raffaelj/cockpit_CpMultiplaneBundle.git cockpit/addons/CpMultiplaneBundle

I did not understand, however, if it is needed.

I have installed all the addons that are required here: https://multiplane.rlj.me/en/addons

In any case, I have tried in every way to configure as required by the guide but I cannot see the pages and the menu. I only see the logo, the site name and the languages.
I noticed that on the pages (see attachment) there are some settings that currently are not there.

Where am I wrong?

@Sebastian I’m glad, that you’re interested in this project.

This is a bit outdated, sorry. Writing the docs takes so much time for a spare time project… Also, sometimes I don’t see things, that aren’t user friendly, because I know every line of code in this project. But hopefully, I can help you getting started.

This is also outdated. Bundling the addons was a bad idea. It was hard to keep everything up to date and to do tests with bundled and unbundled modules.

Yes, this is the latest release with auto created dummy data from the installed addons. If you have all of them, you have a good base to start with.

If you need inspiration to configure the addons, have a look at the templates folder.

Now, step by step…

  • CpMultiplane is in the docs root
  • Cockpit is in docs_root/cockpit
  • CpMultiplanGUI addon is installed
  • Copy or rename .htaccess.dist to .htaccess
  • Create a collection for pages --> in the collection settings enable the option to use the custom sidebar
  • Go to the CpMultiplane settings and create a profile, select your collection as pages collection
  • Tell CpMultiplane to use that profile, see: https://github.com/raffaelj/CpMultiplane#settings
  • Create pages
    • –> at least one of them must be the startpage, otherwise that page was not found (see screenshot below, bottom right at the mouse cursor)
    • for other pages, enable the navigation “main” or “footer”, also in the side bar

Feel free to ask more questions.

I don’t see this setting in admin page (main, footer, subpages, set special page types)…

You have to set the type to “Pages”, too. I differentiate between a single pages collection and optional multiple sub pages collections, with different side bars.

This is my config.php in cockpit/config/config.php


<?php
return [
    'app.name' => 'Multi',

    'i18n' => 'en',
    'languages' => [
        'default' => 'English',
        'de' => 'Deutsch',
    ],

    // define settings here
    'multiplane' => [
    	'profile' => 'siteA',
    	'slugName' => 'slug',
    	'navName' => 'menu',
        'pages' => 'pages',
        'siteSingleton' => 'site',
        'slugName' => 'slug',
        'use' => [
            'collections' => [
                'pages',
                'Posts',
            ],
            'singletons' => [
                'site',
            ],
        ],
    ],
    'unique_slugs' => [
        'collections' => [
            'pages' => 'pages',
            'posts' => 'posts',
         ],
        'localize' => [
            'pages' => 'pages',
            'posts' => 'posts',
         ],
    ],      
];

I configured the pages as per the attached image but I don’t see the settings.

In the collection settings of your pages collection, below “Enable sidebar”, there you have to select the type “Pages”. Than the pages side bar should appear.

You don’t have to use a profile and all the options in the config file. I made the profiles to be able to switch easily between them and to be able to copy and paste them to new projects. Also the settings defined in your config file overwrite the profile settings.

should be:

    'unique_slugs' => [
        'collections' => [
            'pages' => 'title',
            'posts' => 'title',
         ],
        'localize' => [
            'pages' => 'title',
            'posts' => 'title',
         ],
    ],      

to create slugs from the title field.