Asset Manager keep loading thumbnail

Hi there!

Suddenly the Asset Manager cannot show the thumbnail, it keeps showing the spinner animation.
Yesterday everything is going fine.
Kindly check this screenshot:

I tried to check another Cockpit installation in the same server, the Asset Manager is doing fine. I think there is an error when generating thumbnail.

How do troubleshoot it?
any idea how to solve this?

can you inspect the browsers networkpanle and what is returned by the server for the image requests?

Hi artur,

this is what returned:

I tried to logs what happens in
thumbnail function.

the path is correct, the thumbnail is generated. but somehow in this line

echo $this->app->filestorage->read($thumbpath);
returns empty

Below is the logs:

generate thumbnail





Filestorage read function >>



Any idea ?

Finally this issue is solved.

The problem is one of my addon has extra space after the PHP closing tag, i think it’s because of some editor automatically convert linebreak.

Thank you for your support @artur