Reordering items in repeater field does not update the response

I have a field of type repeater, which contains a set with 3 fields.
When I use the reorder functionality on them, I can resort them nicely in the UI. The new order does however not reflect what I receive when fetching the data from the endpoint. It is still the original order.

What am I doing wrong?

What’s your cockpit version?

And maybe a stupid question, but it happened to me multiple times… Did you save the entry after reordering?
Or do you have a multilingual setup and you fetched the wrong language, where the repeater wasn’t reordered?

I am on cockpit 0.11.0

After trying this now for about 15 minutes I do not really understand the behavior. It does work in 90% of the times actually. But every now and then it does not. Clicking the save button 3-4 times then, fixes it.

Maybe sometimes the reordering is not kicked off? Or same caching issue. Not sure :slight_smile:

Weird… Could you provide some more details to be able to reproduce the issue?

  • Which browser?
  • Is debug mode enabled (default on localhost)? --> than all scripts are loaded with a timestamp on each request --> could cause browsers to fill up a lot of RAM --> could than cause js errors and delays
  • list of addons

Okay, I finally tracked down the issue with this. It is actually not a bug, but an inconsistency in cockpits UX. Normally all changes in cockpit are basically stored in the background and written to the database when clicking save. Just for the reordering there is an extra button. I am 99.9% sure, that the issue here was, that not everyone in the team realized, that they had to click the “Update order” button explicitly.

That inconsistency led to some of our users assume, that the saving did not work.