Cockpit MongoDB Atlas

Hello,

would like to move my Cockpit to MongoDB Atlas (Free Plan).
But have some problems.

Currently I have a new cockpit instance with a configuration file.

In the configuration I have the following setting:

'database' => [
    'server' => 'mongodb+srv://cluster0.jl4de.mongodb.net/cockpitdb?retryWrites=true&w=majority',
    'options' => [
        'db' => 'cockpitdb',
        'username' => '######',
        'password' => '######',
    ]
],

For server I decided to use this connection string:

mongodb+srv://cluster0.jl4de.mongodb.net/cockpitdb?retryWrites=true&w=majority

My current problem is that I get an ERR_EMPTY_RESPONSE after doing the configuration.

As a test I have manipulated the connection string, then I got from the cockpit error that can not be connected.

Means a connection is established, but except an ERR_EMPTY_RESPONSE I see no other errors.

Calling /install is also not possible.

Can someone help me here?

Missing the password in URL.

Click connect button.


Copy connection string and replace <password> with your password.

Problem solved, regardless that in the example the credetials are missing, I rather have on OSX a local problem with MAMP and the mongoDB connector.

In cockpit docker it works fine :slight_smile: