# Undefined index: user\_group in /var/www/website/cms/addons/GroupBoundAssets/bootstrap.php

**URL:** <https://discourse.getcockpit.com/t/undefined-index-user-group-in-var-www-website-cms-addons-groupboundassets-bootstrap-php/2149>\
**Category:** Support\
**Created:** [November 24, 2021, 11:54am UTC](https://discourse.getcockpit.com/t/undefined-index-user-group-in-var-www-website-cms-addons-groupboundassets-bootstrap-php/2149 "2021-11-24T11:54:14Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mel](https://avatars.discourse-cdn.com/v4/letter/m/da6949/32.png) [@Mel](https://discourse.getcockpit.com/u/Mel)\
**Post date:** [November 24, 2021, 11:54am UTC](https://discourse.getcockpit.com/t/undefined-index-user-group-in-var-www-website-cms-addons-groupboundassets-bootstrap-php/2149/1 "2021-11-24T11:54:15Z")

</div>

Hi there!

I have a website set up with Cockpit (0.8.11) which has worked as hoped up until now.

Currently we have an issue with uploading assets (trying to add a profile image to the ‘Meet the Team’ page). When we try to upload an image on Cockpit it gives a ‘Something went wrong’ message and a ‘/assetsmanager/upload: Failed to load resource: the server responded with a status of 500 (Internal Server Error)’ in the console.

Looking in the Apache server logs, there is the following error:

`PHP Notice: Undefined index: user_group in /var/www/website/cms/addons/GroupBoundAssets/bootstrap.php`

Here is a screenshot of that bootstrap.php file:

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/getcockpit/original/1X/a17978b7b0754ac607606be2271ff36360e53d77.png)

In the system settings, the following was added as config.yaml:

```auto
# define additional groups
    'groups' => [
        'author' => [
            '$vars' => [
                'finder.path' => '/storage/upload'
            ]
        ]
    ],
    helpers:
        debug: false
        environment: production
        collectionSelect: true
        singletonSelect: true

```

I’m new to working with Cockpit and wasn’t involved in the set up of this site.

I’ve checked that the image is below 500k as that was specified in the .htaccess file. I am unable to access the Recent Logs tab in Cockpit as it just has an unending load.

If anyone has come across anything similar, any advice would be really appreciated! Thanks so much in advance

---

<div class="post-metadata">

**Author:** ![serjoscha87](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/serjoscha87/32/151_2.png) [@serjoscha87](https://discourse.getcockpit.com/u/serjoscha87)\
**Post date:** [November 26, 2021, 10:21pm UTC](https://discourse.getcockpit.com/t/undefined-index-user-group-in-var-www-website-cms-addons-groupboundassets-bootstrap-php/2149/2 "2021-11-26T22:21:25Z")

</div>

My GroupBoundAssets Addon is very outdated - don’t think it is working anymore - sorry
