# Cannot reach cockpit in deployed app

**URL:** <https://discourse.getcockpit.com/t/cannot-reach-cockpit-in-deployed-app/330>\
**Category:** Support\
**Created:** [October 11, 2018, 7:18pm UTC](https://discourse.getcockpit.com/t/cannot-reach-cockpit-in-deployed-app/330 "2018-10-11T19:18:20Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![hellmaca](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/hellmaca/32/126_2.png) [@hellmaca](https://discourse.getcockpit.com/u/hellmaca)\
**Post date:** [October 11, 2018, 7:18pm UTC](https://discourse.getcockpit.com/t/cannot-reach-cockpit-in-deployed-app/330/1 "2018-10-11T19:18:20Z")

</div>

I have deployed an app from GitHub using a Jenkins pipeline to Pivotal Cloud Foundry. I am able to reach my index.html page, but trying to reach cockpit gets me a 500 error. Eventually I plan to use mongodb, but I wanted to see if I could get it up and running first with just sqlite. I am wondering if I am missing something in the config files. Everything works great locally using MAMP. Any help or advice is much appreciated.

---

<div class="post-metadata">

**Author:** ![serjoscha87](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/serjoscha87/32/151_2.png) [@serjoscha87](https://discourse.getcockpit.com/u/serjoscha87)\
**Post date:** [October 12, 2018, 4:47pm UTC](https://discourse.getcockpit.com/t/cannot-reach-cockpit-in-deployed-app/330/2 "2018-10-12T16:47:41Z")

</div>

if you are running an apache webserver try commenting in the rewritebase row within the .htaaccess (not quite sure if this will fix your issue, but I had the same problem once and commenting the rewrite base back in again fixed if for me)

---

<div class="post-metadata">

**Author:** ![hellmaca](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/hellmaca/32/126_2.png) [@hellmaca](https://discourse.getcockpit.com/u/hellmaca)\
**Post date:** [October 12, 2018, 5:59pm UTC](https://discourse.getcockpit.com/t/cannot-reach-cockpit-in-deployed-app/330/3 "2018-10-12T17:59:56Z")

</div>

Unfortunately, that fix did not work. I realize I have been able to get Drupal installed in the past. I will try to compare the setup to see if an answer can be found there. I think it has something to do with my buildpack.

---

<div class="post-metadata">

**Author:** ![hellmaca](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/hellmaca/32/126_2.png) [@hellmaca](https://discourse.getcockpit.com/u/hellmaca)\
**Post date:** [October 15, 2018, 8:09pm UTC](https://discourse.getcockpit.com/t/cannot-reach-cockpit-in-deployed-app/330/4 "2018-10-15T20:09:35Z")

</div>

Solved this issue, but created another one. When looking at my logs I noticed an error was occurring when checking which version of Apache I have. I removed the check after checking my version number. Now I have to give write access to some of the directories in the storage folder. Trying to figure that out now.

---

<div class="post-metadata">

**Author:** ![hellmaca](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/hellmaca/32/126_2.png) [@hellmaca](https://discourse.getcockpit.com/u/hellmaca)\
**Post date:** [October 16, 2018, 2:49pm UTC](https://discourse.getcockpit.com/t/cannot-reach-cockpit-in-deployed-app/330/5 "2018-10-16T14:49:45Z")

</div>

I am getting these errors when trying to install:

- PDO extension loaded with Sqlite support

- Data folder is not writable: /storage/data

- Cache folder is not writable: /storage/cache

- Temp folder is not writable: /storage/tmp

- Uploads folder is not writable: /storage/uploads

When I check my phpinfo I am showing sqlite as installed. If I ssh into the server and create the directories that are said not to be writable the errors disappear except for the pdo extension error. From what I can tell it is installed. I am not sure why I can’t get it to work with cockpit though.

edit: solved with newest version of cockpit
