# A bit of random error 404 when setting up cockpit

**URL:** https://discourse.getcockpit.com/t/a-bit-of-random-error-404-when-setting-up-cockpit/2829
**Category:** Support
**Created:** [July 8, 2023, 6:12am UTC](https://discourse.getcockpit.com/t/a-bit-of-random-error-404-when-setting-up-cockpit/2829 "2023-07-08T06:12:52Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sjoerd222888](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/sjoerd222888/32/1371_2.png) [@sjoerd222888](https://discourse.getcockpit.com/u/sjoerd222888)
#### Post date: [July 8, 2023, 6:12am UTC](https://discourse.getcockpit.com/t/a-bit-of-random-error-404-when-setting-up-cockpit/2829/1 "2023-07-08T06:12:52Z")

</div>

Hi

I did install cockpit CMS on a hosting provider that runs php 8.2 on Apache.  
First I installed it once on a separate subdomain and it all worked. I was able to create models, content, users, roles, api-keys. This was my playground.  
Then I installed it again, this time in a subfolder of an existing environment. It looked fine at first. I could create models, content, user, api-key. Then I create a user-role but after I created it I could not manage roles any longer. Attemtping to navigate to manage roles would result in a 404 page.  
Then I installed it again in a subdomain, directly on the root and it seemed again all to work but after I have created the models I could not access them. Each time I want to edit them or add content I end up on a 404 page.  
I tried again the page where I installed cockpit on a sub folder and for some reason all of a sudden I am able to manage roles there again. I wonder if a cleanup from the hosting provider somehow has solved this problem.

Now I want to ask: What means do I have with cockpit CMS to investigate the issue and find out what is going wrong. I see there is a log folder but I see no logs there. I cannot access the apache logs, only the hosting provider can. I see there is a debug mode in cockpit, I am not clear what it does and how I could activate it.

What can I do?

---

<div class="post-metadata">

### Author: ![artur](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/artur/32/4_2.png) [@artur](https://discourse.getcockpit.com/u/artur)
#### Post date: [July 8, 2023, 2:02pm UTC](https://discourse.getcockpit.com/t/a-bit-of-random-error-404-when-setting-up-cockpit/2829/2 "2023-07-08T14:02:14Z")

</div>

Hi 👋

Do you have access to apache and php error logs?

---

<div class="post-metadata">

### Author: ![sjoerd222888](https://yyz2.discourse-cdn.com/flex030/user_avatar/discourse.getcockpit.com/sjoerd222888/32/1371_2.png) [@sjoerd222888](https://discourse.getcockpit.com/u/sjoerd222888)
#### Post date: [July 9, 2023, 7:59am UTC](https://discourse.getcockpit.com/t/a-bit-of-random-error-404-when-setting-up-cockpit/2829/3 "2023-07-09T07:59:39Z")

</div>

Unfortunately not, no.
